今天为了把一个HTML的A标记做一个链接,但是点击后有虚框,看起来很是不爽。于是去BAIDU.结果BAIDU千篇一律的相同的。。不过都是不可用的。郁闷。。。还是去GOOGLE吧。运气好。第二条记录便是我想要的。感谢CSSBABY的方案,非常好用。。不过这个方法不怎么统一哈。。没办法,浏览器厂商是这样的。我们只有这样解决啦。。。

   

当一个链接得到焦点时,默认会有个虚线框。如图:

链接虚线框

Read More →

从网上收集来的关于IE各种版本的CSS识别方式,如果,以后免得到处找。

  • <!–[if !IE]><!–> 除IE外都可识别 <!–<![endif]–>
  • <!–[if IE]> 所有的IE可识别 <![endif]–>
  • <!–[if IE 5.0]> 只有IE5.0可以识别 <![endif]–>
  • <!–[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]–>
  • <!–[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]–>
  • <!–[if IE 6]> 仅IE6可识别 <![endif]–>
  • <!–[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]–>
  • <!–[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]–>
  • <!–[if IE 7]> 仅IE7可识别 <![endif]–>
  • <!–[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]–>
  • <!–[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]–>

本文为原作希望转载标明出处和作者!

这前在网站上Eclipse开发JQuery环境设置(Spket) 文章提到过JQuery提示插件,但是经过多次的试验不尽人意,主要是其提示效果不理想,而且配置成功的概率非常的小。经过同事的推荐使用aptana插件还不错其代码提示功能非常的强大,而且aptana有自己独立的IDE。详细见:http://www.aptana.org/ 本文介绍在Eclipse下安装该插件,目的主要是解决jquery在eclipse下的代码提示。

注意选择eclipse 3.5,而且现在只能选择3.5,选择高版本的3.6会出现bug,以致插件管理器不能使用,当然也就用不了jquery插件了。。。

=================================================

【2010-11-10更新】最近发现它支持3.6,不过是BETA版,还是不错了:

插件更新地址:http://download.aptana.com/studio3/plugin/install

Read More →